System Requirements

Supported Operating Systems
(Home Editions are not supported)
CAMWorks 2015 CAMWorks 2016 CAMWorks 2017 CAMWorks 2018
Windows 7 SP1 (64-bit only)
Windows 8.1 (64-bit only)
Windows 10 (64-bit only)
 
CAMWorks is supported on the following CAD products
Supported Solid Modeler Versions CAMWorks 2015 CAMWorks 2016 CAMWorks 2017 CAMWorks 2018
Solidworks 2011/CAMWorks Solids 2011
Solidworks 2012/CAMWorks Solids 2012
Solidworks 2013/CAMWorks Solids 2013
Solidworks 2014/CAMWorks Solids 2014
Solidworks 2015/CAMWorks Solids 2015
Solidworks 2016/CAMWorks Solids 2016 (SP2)
Solidworks 2017/CAMWorks Solids 2017 (SP3)
Solidworks 2018/CAMWorks Solids 2018 (SP3)
 
Solid Edge ST5 (MP8 or higher)
Solid Edge ST5 (MP10 or higher)
Solid Edge ST6 (MP4 or higher)
Solid Edge ST6 (MP8 or higher)
Solid Edge ST7 (MP8 or higher)
Solid Edge ST8 (MP4 or higher) (SP2)
Solid Edge ST9 (MP00 or higher) (SP3)
Solid Edge ST10 (MP00 or higher) (SP2)
 
Supported database formats
Databases CAMWorks 2015 CAMWorks 2016 CAMWorks 2017 CAMWorks 2018
Access 2003 (32 bit)
Access 2007 (32 bit)
Access 2010 (32 bit)
Access 2010 SP1,2 (64 bit)
Access 2013 (32 bit)
Access 2013 (64 bit)
Access 2016 (32 bit)
Access 2016 (64 bit)
SQL Server 2008, R2, 2014, 2016
CAMWorks DB


Hardware Requirements (Minimum)
for SOLIDWORKS and
for CAMWorks Solids
https://www.solidworks.com/sw/support/SystemRequirements.html
for Solid Edge https://www.plm.automation.siemens.com/en_us/products/solid-edge/design/system_requirements.shtml
X